Description
IP cameras are successfully added and displayed on the Camera list, but the status is disconnected.
Note:
We recommend updating the NVR firmware to the latest version before starting. The latest version can be downloaded from the Download Center|Milesight.
Cause
1. Incorrect camera information on the NVR side
2. Connection limitation between camera and NVR
3. Video Codec Type limitation
Resolution
1. Incorrect camera information on the NVR side
To successfully add the camera to the NVR, these 4 key parameters must be correct, which include username, password, port and protocol type as shown below:
1.1 Username and Password
Ensure there is no problem when login into camera web page with the same username and password.
Note:
Generally, Milesight camera doesn’t have default password. You need to activate the camera first and set the desired password. However, for some old version models which shipped before 2019, the default username is “admin”, and the default password is “ms1234”.
1.2 Port
On the NVR side, the default port of MSSP, ONVIF protocol is 80, and the default port of RTSP protocol is 554. For specific ports, please refer to specific settings.
Also, when you connect to the camera through the Internet, whether you use MSSP or ONVIF protocol, you need to port map the Camera RTSP port. Cause the camera will play RTSP stream under Live View interface. The Live View of devices cannot be played normally if the RTSP port of devices are not mapped.
Note:
Milesight cameras support UPnP function. If you map the camera through the port, you need to consider the effect of UPnP.
l UPnP is Enabled
You need to input the corresponding External Port of UPnP. For example, you need to input 3346 on the NVR side when the UPnP settings as shown below.
l UPnP is Disabled
You need to input the corresponding External Port of router. For example, you need to input 8008 on the NVR side when UPnP is disabled and router settings as shown below.
1.3 Protocol Type
If you want to play RTSP stream, you need to select RTSP protocol.
Note:
l The default RTSP port is 554
l Milesight camera RTSP address:
Primary Streamrtsp://IP:RTSP Port/main
Secondary Streamrtsp://IP:RTSP Port/sub
Tertiary Streamrtsp://IP:RTSP Port/third
l Milesight NVR RTSP address:
RTSP formatrtsp://IP:RTSP port/ch_xxx
ch_xxx: The first number of xxx represents stream type, 1 for main stream and 4 for sub stream. The last two represent channel numbers, which start from “00” (“00” means channel 1).
Take “rtsp://192.168.8.179:554/ch_402” as an example: The IP address of NVR is 192.168.8.179.
The RTSP port is 554.
The stream type is sub stream and the channel number is 3.
l Also, you need to check whether the RTSP stream is normal. Ensure the RTSP stream of camera is available. You can test it via VLC player as shown below:
Ensure the RTSP stream of NVR is available. You can test it via VLC player as shown below:
2. Connection limitation between camera and NVR
2.1 IP segment of camera and NVR are different
Ensure the IP segment of the Milesight camera is consistent with the NVR.
2.2 Maximum Number of Concurrent Streaming on the Camera side
Ensure the number of camera connections reaches the Maximum Number of Concurrent Streaming.
Note:
The default value of Maximum Number of Concurrent Streaming is 9.
2.3 IP Access List at camera side
Check whether the cameras are online and the IP access of the NVR has been restricted on the camera side.
2.4 Free Receiving Bandwidth on the NVR side
Ensure that Free Receiving Bandwidth has enough bandwidth on the NVR side. In some cases, the cameras will display “Disconnected” if the Free Receiving Bandwidth is not enough even though the Live View can play normally.
2.5 Access Filter on the NVR side
Check whether the IP/MAC access of the cameras have been restricted on the NVR side.
3. Video Codec Type limitation
3.1 MJPEG Video Codec Type
Due to NVR doesn’t support MJPEG video codec Type, please check the Video Codec on the camera side.
Note:
Milesight NVR supports H.264 and H.265 video codec types.
Others
1. The preview failure problem when adding channels of the NVR to another NVR via RTSP.
Cause: The old version is not compatible with Milesight NVR that does not carry sprop-parameter-sets.
Resolution: Upgrade NVR firmware version to 7X.9.0.12 (2021/6) or above.
2. The cameras with the same IP address but different ports failed to be added successfully.
Cause: The old version is not available to add the same channel CGI interface.
Resolution: Upgrade NVR firmware version to 7X.9.0.12 (2021/6) or above.
Also, you can enable the CGI interface via CGI address as below:
http://192.168.5.200/sdk.cgi?action=set.camera.add_same_channel&enable=1
3. The NVR network setting is in load balance mode. Plugging in network cable will make the IP camera disconnected if there’s another one been plugged in already.
Cause: The old version BUG which caused by network thread check.
Resolution: Upgrade NVR firmware version to 7X.9.0.13 (2021/9) or above.