Description

 

The Third-party IP cameras are successfully added and displayed on the Camera Management list, but the status is disconnected.

 

Note:

We recommend updating the NVR firmware to the latest version before starting. The latest version can be downloaded from the Download Center|Milesight

 

Cause

1. ONVIF Protocol Related

2. Other Parameters Requirements

 

Resolution

 

1. ONVIF Protocol Related

1.1 ONVIF Protocol Support

Milesight NVR that connects to third-party cameras requires ONVIF protocol support. You can test if the ONVIF camera works on ODM(ONVIF Device Manager). It's a program which can be searched through Google, you can download it by yourself.

Ensure the camera can be detected by ODM. It represents the camera supports ONVIF.

Ensure that the camera can be added via ONVIF. Check whether the NVT will display the camera information normally after logging in.

 

Note:

Input the corresponding ONVIF account and click Log in. 

 

Ensure the RTSP stream is available. Check whether the video stream can be played normally after the camera is successfully added through ONVIF. 

 

 

1.2 ONVIF Protocol is NOT Enabled

Ensure the ONVIF is Enabled. 

For most of IP cameras, ONVIF is an optional protocol as shown in the figure below:

 

 

1.3 No ONVIF Account 

Ensure there is at least one ONVIF account available. 

Some third-party brand IP cameras, such as HIKVISION, needs to add ONVIF account but there is no default one. You need to Enable ONVIF and add ONVIF accounts. For example, you can add this camera to NVR through either of these two ONVIF accounts as shown below:

 

 

1.4 Incorrect ONVIF Port

Check the ONVIF port of camera. Ensure the filled ONVIF port is correct.

In most cases, the port of ONVIF is 80, so the default port value of Milesight NVR ONVIF protocol is 80. But some third-party cameras' ONVIF ports are not, such as Grandstream’s is 8080.

 

 

2. Other Parameters Requirements

2.1 Camera and NVR Time Synchronization

Ensure the system time of camera is the same as NVR.

For some third-party brands, like Axis cameras, you need to check whether the time is synchronized with the NVR, because this brand’s camera has time synchronization requirement.

 

 

2.2 Video Codec Type Limitation

Due to Milesight NVR only supports H.264, H.265 video codec type, please pay attention to the camera's MJPEG, H.264+, H.265, H.265+ and smart stream options.

Note: 

Considering that H.265 may have compatibility issues, H.264 is recommended. If you need to be compatible with H.265, please contact Milesight technical support for help.

 

Regarding the video codec type, here is an example: For Panosonic camera, some of them don’t support H.264 video codec type as shown below.

 

Even choose the Stream 1-3 (H.265), Panosonic camera still get response from ODM of JPEG video codec type.

 

As you know, Milesight NVR doesn’t support MJPEG video codec type which proves that these cameras cannot be added to Milesight NVR. Also, about H.265 responding to JPEG, you need to contact Panosonic technical support for help.

 

Others

1. Failed to add Axis, Avigilon, Bosch, Dahua cameras, HIK NVR RTSP stream.

Resolution: Upgrade NVR firmware version to 7X.9.0.12 (2021/6) or above.